We have moved to GitHub! The discussion forums will no longer be maintained on CodePlex.

Multiple nodes with the same key '' were found. XmlSiteMapProvider requires that sitemap nodes have unique keys.

first post: WayneBrantley wrote: In the regular sitemaps, you were allowed to have entries that did ...

latest post: Indramani wrote: I have my sitemap as: <?xml version="1.0" encoding="utf-8" ?> <sit...

why not simply use this site as a release site?

first post: deostroll wrote: Just a suggestion. The latest version of code can be maintained o...

Where do I find a full tutorial, including all steps?

first post: pcyoung wrote: Ok, I have done the following:Registered the provider exactly like ...

latest post: NightOwl888 wrote: An updated tutorial for version 4.0 can be found at the following l...

MVC Sitemap parameters

first post: boystlighttvc88 wrote: Hi Sir/Madam, I has problem for paramester: page2>page3>page4 [Mvc...

Search all node

first post: pablotdv wrote: Hello guys, I'm trying to do a routine that traverses every node ...

latest post: pablotdv wrote: excuse me. error in web.config. the default site map was pointing t...

MvcSiteMapProvider 2.0: node for action with parameters - problem 2

first post: sadomovalex wrote: hello,earlier I wrote about issue with node for action with 1 param...

latest post: sadomovalex wrote: hi it also can be used, but will require to add this attribute to a...

Nodes are skipped for some reason when creating a menu

first post: PaulCallaghan wrote: Hello, I am using this code ...@Html.RenderSideNavigation(Html.MvcS...

latest post: PaulCallaghan wrote: Hi notretro, No, I never resolved the issue and wound up not usi...

How to hide the (url) that shows up in my menu

first post: n8nt wrote: I've just installed version 3.3.3.0 of MVC SiteMap provider using ...

Breadcrumb levels (over 2) not displayed correctly

first post: jj09 wrote: I am using MvcSiteMapProvider and it shows just 2 levels of bread ...

GetDynamicNodeCollection() never called

first post: mickel wrote: Hi guys,I have this problem with dynamicNodeProvider and my impleme...

latest post: weitzhandler wrote: I'm experiencing the same exact issue. Could you please gimme a ha...